Kommandozeilen-Parameter

<< Zum Inhaltsverzeichnis >>

Navigation:  Zeitgesteuerte Untersuchungen >

Kommandozeilen-Parameter

Die Professional Version von TreeSize akzeptiert Kommandozeilen-Parameter, die zeitgesteuerte Untersuchungen erlauben. Mit Hilfe von "TreeSize-Scans planen" aus dem Extras-Menü können Sie einfach einen Aufruf mit den unten stehenden Kommandozeilen-Parametern zusammenstellen. Die allgemeine Syntax für Kommandozeilen-Parameter lautet wie folgt:

Treesize.exe [/OPTION] SCAN-PFAD

 

/?   oder   /HELP        

Zeigt diese Hilfeseite an.

/AGEOFFILES

Speichert das Diagramm auf dem Reiter "Dateialter" des untersuchten Verzeichnisses als Bitmap-, GIF-, PNG-, JPEG-, Text- oder CSV-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Das folgende Beispiel speichert das "Dateialter"-Diagramm für Ihr lokales Laufwerk C: als JPEG-Datei.

Treesize /AGEOFFILES "C:\Dokumente\C_Dateialter.jpg" "C:\"

/APPENDTOFILES <Wert>

Mit dieser Option können Sie entscheiden, ob TreeSize an existierende Dateien anhängen, oder diese überschreiben soll, wenn ein Export angestoßen wird, z.B. wenn /TEXT benutzt wird. Verwenden Sie den Wert "True", um anzuhängen, "False" um zu überschreiben.

Hinweis: Diese Option hat keine Auswirkung auf exportiert Grafik-, XML- und PDF-Dateien. Diese Dateien werden immer überschrieben. Sie können jedoch zusätzlich die Option /DATE benutzen, um sicher zu stellen, dass jede Datei einen eindeutigen Namen erhält.

Beim Export in eine Excel-Datei via /EXCEL kann dieser Parameter zusammen mit /SHEETNAME verwendet werden, um die Daten an das angegebene Sheet anzuhängen. Beispiel:

Treesize.exe /APPENDTOFILES True /EXCEL "C:\Export.xlsx" /SHEETNAME "test" "C:\"

Treesize.exe /APPENDTOFILES False /TEXT "C:\Export.csv" "C:\"

/ARCHIVEBITFILESONLY

Diese Option wird nur solche Dateien in die Scans mit einbeziehen, bei denen das Archiv-Bit gesetzt ist. Dies kann beispielsweise genutzt werden, um die Größe von Backups zu bestimmen. In diesem Fall können Sie eine Verknüpfung zur "TreeSize.exe" auf dem Desktop oder im Startmenü erstellen, die automatisch mit der Berechnung der Größe des Backup beginnt. Beispiel:

Treesize /ARCHIVEBITFILESONLY "\\Server\Backup\"

/ATTACH

Ist diese Option angegeben, so werden alle generierten Dateien auch der E-Mail angehangen. Ist diese Option nicht angegeben, so werden explizit aufgeführte Pfade nicht an eine E-Mail angehangen. Dieses Standardverhalten ist nützlich, damit eventuell sehr große Excel oder XML Dateien nicht ihr E-Mail Postfach füllen.

Dieses Beispiel wird einen Excel Export durchführen, die Datei aber nicht anghängen:

TreeSize.exe /EMAIL "treesize@example.com" /EXCEL "C:\Temp\test.xlsx" "F:\"

Diese Beispiele werden die Excel-Datei an die E-Mail anhängen:

TreeSize.exe /EMAIL "treesize@example.com" /EXCEL "F:\"

TreeSize.exe /EMAIL "treesize@example.com" /ATTACH /EXCEL "C:\Temp\test.xlsx" "F:\"

/BARCHART <Dateiname>

Speichert das Balkendiagramm des untersuchten Verzeichnisses als Bitmap-, GIF-, PNG- oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Das folgende Beispiel speichert das Balkendiagramm Ihres lokales Laufwerks C: als PNG-Datei:

Treesize /CHART "C:\Dokumente\chart-datei.jpg" "C:\"

/COMPARE <Dateiname|Pfad>

Vergleicht den untersuchten Pfad mit einem zuvor gespeicherten XML-Report. Das folgende Beispiel untersucht das Laufwerk C: und vergleicht es anschließend mit einem gespeicherten XML-Report für dieses Laufwerk:

Treesize /COMPARE "C:\Reports\TreeSize\c.xml.zip" "C:\"

An Stelle eines XML-Reports kann auch ein Pfad angegeben werden, der mit dem aktuellen Scan-Ergebnis verglichen wird. Im folgenden Beispiel wird zusätzlich zum Laufwerk C:\ der Pfad D:\Backup_of_C gescannt und die Ergebnisse der beiden Scans miteinander verglichen:

Treesize /COMPARE "D:\Backup_of_C" "C:\"

Alternativ kann man aber auch zwei bereits gespeicherte XML-Reports z.B. "c1.xml.zip" und "c2.xml.zip" miteinander vergleichen, indem man das folgende Kommando benutzt:

Treesize /OPEN "C:\Reports\TreeSize\c1.xml.zip" /COMPARE "C:\Reports\TreeSize\c2.xml.zip"

Die Option /OPEN bereitet den Vergleich der beiden Dateien vor, indem sie "c1.xml.zip" in eine normale Scan-Datei umwandelt. Die zweite Datei ("c2.xml.zip") wird dann mit der Scan-Datei verglichen - genau so, als wenn man "c2.xml.zip" mit dem Ergebnis eines gerade erst erfolgten Scan vergleichen würde.

/COPY <Pfad>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Erlaubt das Kopieren der Ergebnisse der Dateisuche in ein bestimmtes Verzeichnis. Das folgende Beispiel durchsucht Laufwerk C: mit den zuletzt verwendeten Sucheinstellungen und kopiert die Ergebnisse in den Ordner "C:\Temp\ObsoleteFiles":

Treesize /SEARCH:Start /COPY "C:\Temp\ObsoleteFiles" "C:\"

Siehe auch: Dateioperationen

/CREATEDPASTDAYSONLY <N>

Diese Option wird nur solche Dateien in den Scan miteinbeziehen, die innerhalb der angegebenen Anzahl der letzten zurückliegenden Tage erstellt wurden.

Treesize /CREATEDPASTDAYSONLY 8

In diesem Beispiel werden nur Dateien in den Scan miteinbezogen, die innerhalb der letzten 8 Tage neu erstellt worden sind.

Damit korrespondiert der Parameter mit der Option "Nur Dateien mit Erstellungsdatum innerhalb: XX Tage(n)" im Optionen Dialog.

/CREATESNAPSHOT <Laufwerk>

Erstellt einen Snapshot für die Laufwerke, die nach diesem Kommandozeilen-Parameter übergeben werden. Beispiel:

Treesize /CREATESNAPSHOT "C:\" "D:\"

Bitte beachten Sie: Zum Anlegen von Snapshots werden typischerweise Administrator-Rechte benötigt.

/DATE

Diese Option fügt jedem Dateinamen in diesem Kommandozeilen Aufruf, in dem Ergebnisse gespeichert werden, Datum und Uhrzeit hinzu. Dies ist besonders nützlich, wenn man regelmäßig zeitgesteuerte Untersuchungen durchführt. Das folgende Beispiel würde den Netzwerkpfad "\\Host\Share" untersuchen und das Ergebnis unter einem Dateinamen der Art "C:\Scans\name_2013-08-14_17-18-24.xls" speichern:

Treesize /DATE /EXCEL "C:\scans\name.xls" "\\Host\Share"

/DEDUPLICATE

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.

Am Ende der TreeSize Duplikatsuche werden die doppelten Dateien der Ergebnisliste durch Hardlinks ersetzt.

Treesize /SEARCH:Start /DEDUPLICATE "C:\"

/DELETE

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Mit diesem Parameter werden Dateien, die als Ergebnisse der Dateisuche gefunden werden, dauerhaft gelöscht. Beispiel:

Treesize /SEARCH:Start /FILTER "*.tmp" /DELETE "C:\temp"

Siehe auch: Dateioperationen

/EMAIL <Empfänger-Adresse>

Sendet die gesammelten Daten an die angegebene E-Mail-Adresse.  Dieser Parameter darf nur einmal an der Kommandozeile verwendet werden, es wird nur eine Mail mit allen Daten gesendet. Es können mehrere Empfänger angegeben werden, die jeweils durch ein Semikolon oder Komma getrennt werden müssen. Für den E-Mail-Versand durch die Kommandozeile muss eine gültige SMTP-Konfiguration auf der entsprechenden Seite im Optionen-Dialog von TreeSize hinterlegt worden sein. Beispiel:

Treesize /EMAIL treesize@example.com "\\Server\Share"

Wenn keine weiteren Parameter angeben wurden, wird die E-Mail in dem Format versendet, das in den Optionen definiert wurde (HTML oder Text). Wenn Sie das Format unabhängig von den Optionen festlegen möchten, fügen Sie bitte den Parameter /TEXT oder /HTML im Anschluss an die Empfängeradresse(n) an. Beispiel:

Treesize /EMAIL treesize@example.com /TEXT "\\Server\Share"

Um der E-Mail einen Anhang hinzuzufügen, können Sie außerdem weitere Parameter angeben. Das folgende Beispiel fügt einen Excel-Export des Scans als Anhang zur E-Mail hinzu:

Treesize /EMAIL treesize@example.com /EXCEL "\\Server\Share"

/EMAILIFRESULTSFOUND

Diese Option kann nur zusammen mit den Kommandozeilen-Optionen /SEARCH und /EMAIL verwendet werden. Mit Hilfe dieses Parameters lässt sich festlegen, dass TreeSize nur dann eine E-Mail mit den Suchergebnissen versendet, wenn auch mindestens eine Datei oder ein Verzeichnis gefunden wurde.

 

/EMPTYRECYCLEBIN

Mit dieser Option können Sie TreeSize veranlassen vor dem Scan den Papierkorb zu leeren. Beispiel:

Treesize /EMPTYRECYCLEBIN "C:\"

/EXECUTE <Dateiname>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Mit diesem Parameter werden Dateien, die als Ergebnisse der Dateisuche gefunden werden, an eine ausführbare Datei übergeben. Als Ziel kann zum Beispiel ein Batch-, oder ein Powershell-Script verwendet werden. Das folgende Beispiel durchsucht Laufwerk C: mit den zuletzt verwendeten Sucheinstellungen und ruft für jede gefundene Datei das Script "Archive.bat" auf. Die Datei wird als Kommandozeilenparameter an das Script übergeben:

Treesize /SEARCH:Start /EXECUTE "C:\Scripts\Archive.bat" "C:\"

Siehe auch: Dateioperationen

/EXCEL <Dateipfad>

Exportiert die gesammelten Ergebnisse im Microsoft Excel-Format und speichert sie unter dem angegebenen Dateipfad ab. Falls nur ein Dateiname angegeben wurde, wird das aktuelle Installationsverzeichnis als Speicherort verwendet. Unterstützt werden sowohl das klassische .XLS-Dateiformat (Excel 97-2003) als auch das mit Excel 2007 eingeführte .XLSX-Format. Das Format wird über die Dateiendung bestimmt.  TreeSize wird anschließend automatisch beendet. Beispiel:

Treesize /EXCEL "C:\Dokumente\c.xls" "C:\"

Existiert die bereits eine Datei mit diesem Namen, so wird diese geöffnet und die Ergebnisse auf einem neuen Tabellenblatt hinzugefügt. Bei der TreeSize Dateisuche (/SEARCH) werden die Ergebnisse jeder Suchart auf ein separates Tabellenblatt exportiert und existierende Dateien werden überschrieben. Um dies zu vermeiden, muss zusätzlich die Kommandozeilen-Option /APPENDTOFILES angegeben werden.

/EXCLUDE <Muster1;Muster2;...>

Diese Option erlaubt die Angabe von Mustern für Dateien und Ordner, die bei der Untersuchung ignoriert werden sollen. Mehrere Muster können jeweils durch ein Semikolon (;) getrennt werden. Enthält ein Suchmuster Leerzeichen, so muss die gesamte Zeichenfolge in Anführungszeichen (") gesetzt werden, so wie es im Beispiel unten zu sehen ist. Das folgende Beispiel würde Ordner und Dateien ignorieren, die auf ".tmp" enden oder deren Name "system" ist:

Treesize /EXCLUDE "*.tmp;system" "\\Server\Users"

/EXPAND <Ebene|Größe>

Mit diesem Parameter kann festgelegt werden, wie viele Ebenen des Verzeichnisbaumes eingeblendet werden, nachdem die Untersuchung abgeschlossen ist. Wird keine Zahl nach diesem Parameter angeben, so wird der komplette Verzeichnisbaum eingeblendet. Es kann auch eine Mindestgröße für einzublendende Verzeichnisse in Mega Byte (MB) angegeben werden. Bitte beachten Sie, dass sich zwischen der Zahl und der Einheit "MB" kein Leerzeichen befinden darf. Das folgende Beispiele untersucht den Ordner "H:\Users", expandiert alle Ordner die größer als 10 MB sind und speichert den Scan in der Exceldatei "C:\Results\Allusers.xlsx":

Treesize /EXCEL "C:\Results\Allusers.xlsx" /EXPAND 10MB "H:\User"

/EXPANDABLEREPORT <Wert>

Mit dieser Option werden Verzeichnisse und Dateien in Excel-Exporte anhand der Verzeichnisstruktur gruppiert, sodass einzelne Ebenen auf- und zugeklappt werden können.

Treesize /EXPANDABLEREPORT True /EXCEL "C:\Results\Allusers.xlsx" "H:\User"

Treesize /EXPANDABLEREPORT False /EXCEL "C:\Results\Allusers.xlsx" "H:\User"

/EXPORTDRIVESLIST <Dateiname>

Diese Option exportiert den Inhalt der "Laufwerksübersicht" in eine Excel-, Text- oder CSV-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /EXPORTDRIVESLIST "C:\Results\AllDrives.csv"

/EXPORTFILES

Wird dieses Flag angegeben, so werden Dateien in allen Exporten mit exportiert. Diese option is also äquivalent dazu, die Options "Extras > Optionen > Export > * > Exportierte Elemente > Ordner und einzelne Dateien" zu aktivieren.

/EXPORTGROUPSEXPANDED

Wird diese Option angegeben, werden die Dateigruppen der Statistik über die Verteilung der Dateitypen vor einem Export expandiert und entsprechend mit in den Export aufgenommen.

/EXPORTPATHSLIST <Dateiname>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.

Exportiert eine einfache Liste der Suchergebnisse. Die Liste enthält ausschließlich die Dateipfade der Suchergebnisse, Meta-Informationen werden nicht hinzugefügt. Unterstützte Dateiformate für die Zieldatei sind .txt und .csv.

Das folgende Beispiel sucht nach allen Dateien mit der Endung exe auf Laufwerk C: und export deren Pfade in eine Datei:

Treesize /SEARCH:Start /FILTER "*.exe" /EXPORTPATHSLIST "C:\Results\SearchResults.csv" "C:\"

Eine solche Pfad-Liste kann verwendet werden, um Ergebnisse einer vorher ausgeführten Suche in die Benutzeroberfläche zu importieren, entweder über "Datei > Liste der Pfade > Pfade importieren", oder mit Hilfe des Kommandozeilenparameters /IMPORT.

Ist die Option "Extras > Optionen > Export > Duplikatgruppen einbeziehen" aktiviert, können auch Ergebnisse der Duplikatsuche mitsamt Ihrer Gruppierung importiert werden.

/EXPORTTITLE <Titel>

Kann genutzt werden, um den Titel des gedruckten oder exportierten Reports zu ändern und so noch zusätzliche Informationen in dem Export anzugeben. Die Nutzung von Umgebungsvariablen ist erlaubt. Beispiel:

Treesize /EXPORTTITLE "Dies ist ein Report von Laufwerk C auf Server3" /PRINT "\\Server3\C$"

/EXTENSIONSLIST <Dateiname>

Diese Option schreibt die Statistik über die Verteilung der Dateitypen/Dateiendungen des untersuchten Dateisystemzweiges in eine Excel-, HTML-, Text- oder CSV-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Die exportierten Spalten sind diejenigen, die zuvor in der Benutzeroberfläche auf dem Reiter "Dateitypen" aktiviert waren, bzw. beim Export der via /OPTIONS übergebenen Konfigurationsdatei.

Das folgende Beispiel untersucht Laufwerk C: und erstellt eine Excel-Datei namens "D:\TreeSize Reports\C_filetypes.xls" mit der Statistik der Dateitypen auf diesem Laufwerk:

Treesize /EXTENSIONSLIST "D:\TreeSize Reports\C_filetypes.xls" "C:\"

/EXTENSIONSCHART <Dateiname>

Speichert das kleine Diagramm im unteren Bereich der Ansicht "Dateitypen" in eine Grafikdatei (Bitmap, GIF, PNG oder JPEG).

/EXTENSIONSPIECHART <Dateiname>

Speichert ein Kreisdiagramm welches die Verteilung der verschiedenen "Dateitypen" zeigt, in eine Grafikdatei (Bitmap, GIF, PNG oder JPEG).

/FILTER <Muster1;Muster2;...>

Erlaubt das Setzen eines Filters, so dass nur bestimmte Dateitypen wie "*.mp3" oder "*.doc" in den Scan mit einbezogen werden. Es können mehrere Filter übergeben werden, die mittels Semikolon (;) getrennt werden müssen. Das folgende Beispiel sucht nach MP3- und AVI-Dateien im Verzeichnis "Users" auf dem Server:

Treesize /EXCEL "C:\Results\UsersMediaFiles.xls" /FILTER "*.mp3;*.avi" "\\Server\Users"

In Kombination mit der TreeSize Dateisuche (/SEARCH) setzt der Parameter /FILTER die Namensmuster der erweiterten Dateisuche. Um komplexere Suchanfragen zu automatisieren speichern Sie Ihre Suchoptionen und übergeben die gespeichert XML-Datei an der Kommandozeile hinter /SEARCH.

/FOLLOWREPARSEPOINTS

Das Hinzufügen dieser Option zur Kommandozeile von TreeSize bewirkt, dass Mountpoints und externen symbolischen Links, die während eines Scans gefunden werden, gefolgt wird.

/GROUPSCANS

Die Angabe dieser Kommandozeilen-Option führt dazu, dass alle durchgeführten Scans unter einem virtuellen Wurzelverzeichnis zusammengefasst werden. Verwenden Sie /GROUPSCANS FALSE um sicherzustellen, dass kein virtuelles Wurzelverzeichnis verwendet wird.

/HIDESMALLFOLDERS

Diese Optionen erlaubt es Objekte auszublenden, die eine bestimmte Mindestgröße unterschreiten, womit man übersichtlichere Exporte erhält. <value> kann eine Größenangabe sein, welche eine Einheit hinter der Zahl erfordert, oder ein Wert in Bytes in Form einer ganzzahligen Zahl ohne Einheit. Kann nicht zusammen mit /EXPAND verwendet werden. In diesem Beispiel werden nur solche Ordner exportiert, die eine Mindestgröße von 50 MB haben:

TreeSize /HIDESMALLFOLDERS 50MB /EXCEL "C:\Results\DriveC.xlsx" C:\

/HISTORYCHART <Dateiname>

Speichert das Diagramm auf dem Reiter "Historie" des untersuchten Verzeichnisses als Bitmap, GIF, PNG oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Das folgende Beispiel erzeugt eine JEPG Grafikdatei mit dem Diagramm der Historie für Laufwerk C:

Treesize /HISTORYCHART "C:\Dokumente\C_Historie.jpg" "C:\"

/HTML <Dateiname>

Speichert die gesammelten Daten in einer HTML-Datei, welche dann mit jedem Internet-Browser angeschaut werden kann. Über "Start > Optionen > Export > HTML > Diese Diagramme und Listen einschließen kann ausgewählt werden, welche zusätzlichen Listen und Diagramme zum HTML-Export hinzugefügt werden sollen. Die Dateien werden am Ende des Scans automatisch in die HTML-Datei eingebunden.

Das folgende Beispiel erzeugt einen HTML-Report für das Laufwerk C: und speichert diesen im Verzeichnis "D:\HTML":

Treesize /HTML "D:\HTML\treesize.html" "C:\"

Wenn Sie gerne mehrere Verzeichnisse oder Laufwerke untersuchen und exportieren möchten, empfehlen wir, entweder einen gesonderten Aufruf von TreeSize für jedes Laufwerk/Verzeichnis, oder die Kommandozeilen-Parameter in der folgenden Art zu verwenden:

Treesize /HTML "D:\HTML\drive_c.html" "C:\" /HTML "D:\HTML\drive_d.html" "D:\"

Wenn Sie möchten, dass mehr als ein Scan Teil der HTML-Datei wird, sollten Sie zusätzlich die Kommandozeilen-Option /GROUPSCANS hinzufügen. Wenn Sie nach HTML exportieren ohne eine zusätzliche Grafik einzubetten, können Sie auch die Option /APPENDTOFILES verwenden. Ohne eine dieser Optionen wird die HTML-Datei für jeden Scan überschrieben.

/IMPORT <Dateiname>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.

Importiert eine Liste von Pfaden und fügt diese zur Benutzeroberfläche der TreeSize Dateisuche hinzu. Die Datei sollte im Format .txt, or .csv sein. Dieser Parameters erlaubt es, Ergebnisse einer zuvor durchgeführten Suche zu laden, welche dann mit Hilfe des Dialogs für Dateioperationen archiviert, kopiert, verschoben oder gelöscht werden können.

Beispiel:

Treesize /SEARCH /IMPORT "C:\Results\filelist.txt"

Dieser Parameter kann auch mit Parametern /RECYCLE, /DELETE und /MOVE kombiniert werden, um automatisch alle Dateien aus der angegebenen Textdatei zu löschen, oder zu verschieben. Zum Beispiel:

Treesize /SEARCH /IMPORT "C:\Results\filesToDelete.csv" /MOVETO "Recycle Bin"

/IMPORTPATTERNS <Dateiname>

Importiert eine Liste von Filtern aus einer Datei. Die Datei kann zum Beispiel eine .txt Datei sein, die eine einfache Liste aus Suchmustern enthält, die jeweils per Semikolon voneinander getrennt werden. Darüber hinaus können eine komplexere Filterkombinationen geladen werden, welche zuvor in der Benutzeroberfläche im XML Format exportiert wurden. Unterstützt werden die Formate CSV, TXT, sowie XML.

Importierte Suchmuster werden als Filter für den Scan angewendet um bestimmte Ordner oder Dateien ein- oder auszuschließen.

In Kombination mit der Kommandozeilenoption /SEARCH, erstellt dieser Parameter eine neue erweiterte Suche welche die aus der Datei geladenen Suchmuster verwendet.

 

Diese Beispiel importiert Filter die innerhalb der Datei "C:\TreeSizeDateien\filter.txt" definiert wurden, startet einen neuen Scan für Laufwerk C:\ und exportiert die Ergebnisse im HTML Format.

Treesize /IMPORTPATTERNS "C:\TreeSizeDateien\filter.txt" /HTML "C:\Results\scanC.html" "C:\"

/LISTSEPARATOR <Trennzeichen> <Trennzeichen>

Erlaubt die Festlegung des Listentrennzeichens, das beim Exportieren von Text- und CSV-Dateien verwendet wird. Standardmäßig wird der Tabulator für Text-Dateien verwendet. Für CSV-Dateien wird standardmäßig das Listentrennzeichen aus den regionalen Einstellungen der Windows Systemsteuerung verwendet. Bitte geben sie hinter dieser Option ein einzelnes Zeichen oder den Text "TAB" für den Tabulator an. Beispiele:

Treesize /LISTSEPARATOR ; /TEXT "C:\Results\c.txt" "C:\"

Treesize /LISTSEPARATOR TAB /TEXT "C:\Results\c.csv" "C:\"

/MOVE <Pfad>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Erlaubt das Verschieben der Ergebnisse der Dateisuche in ein bestimmtes Verzeichnis.

Das folgende Beispiel durchsucht Laufwerk C: mit den zuletzt verwendeten Sucheinstellungen und verschiebt die Ergebnisse in nach "C:\Temp\ObsoleteFiles":

Treesize /SEARCH:Start /MOVE "C:\Temp\ObsoleteFiles" "C:\"

Siehe auch: Dateioperationen

/NOGUI

Diese Option bewirkt, dass das Fenster von TreeSize nicht angezeigt wird und nicht in der Taskleiste erscheint. Diese Option ist nützlich, wenn Sie Untersuchungen oder Suchen im Hintergrund, ohne visuelles Feedback, ausführen wollen.

Achtung: Verwenden Sie dieses Argument erst, wenn Sie die restlichen Kommandozeilen-Parameter ausreichend getestet haben.
Auftretende Fehler werden in der Ereignisanzeige von Windows geloggt.

/NOHEADERS

Führt den Export ohne Kopfzeilen durch, die üblicherweise in die ersten Zeilen der exportierten Dateien geschrieben werden. Dies kann die spätere Weiterverarbeitung der exportierten Daten vereinfachen.

/NOUNITS

Führt den Export ohne die Einheiten durch, die sonst hinter Größenangaben in exportierten Dateien stehen. Verwenden Sie zusätzlich /SIZEUNIT 0, um reine Byte-Werte zu erhalten. Dies kann die spätere Weiterverarbeitung der exportierten Daten vereinfachen.

Hinweis: Diese Option wirkt sich nur auf Exporte des Verzeichnisbaums mittels /TEXT, /EXCEL, /HTML, /EMAIL oder /PRINT aus, nicht aber auf /EXTENSIONSLIST, /USERSLIST, /TOPFILESLIST oder /EXPORTDRIVESLIST.

/OPEN <Dateiname>

Öffnet einen zuvor gespeicherten XML-Report beim Start der Anwendung. Beispiel:

Treesize /OPEN "C:\Reports\Laufwerk_C.xml.zip"

/OPTIONS <Dateiname>

Mithilfe dieses Parameters können Sie zuvor gespeichert Benutzereinstellungen auf TreeSize anwenden. Benutzereinstellungen können unter "Datei > Optionen > Exportieren" exportiert werden. Beispiel:

Treesize /OPTIONS "C:\Temp\Benutzereinstellungen.xml"

Tipp: Stellen Sie vor dem Exportieren so viele Einstellungen wie möglich in der Benutzeroberfläche ein, damit Sie weniger Einstellungen mittels anderer Kommandozeilen-Parameter anpassen müssen.

/PDF

Speichert die Ergebnisse einer Untersuchung oder Dateisuche in einer PDF-Datei, nachdem diese abgeschlossen ist, und beendet anschließen das Programm. Das folgende Beispiel speichert das Ergebnis einer Untersuchung Ihres lokalen Laufwerks C: in einer PDF-Datei:

Treesize /PDF "C:\Results\C_scan.pdf" "C:\"

/PIECHART <Dateiname>

Speichert das Kreisdiagramm des untersuchten Verzeichnisses als Bitmap, GIF, PNG oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Das folgende Beispiel untersucht die Laufwerke C: und D: und erstellt für jedes ein Diagramm im PNG-Format:

Treesize /PIECHART "C:\Reports\C_pie.jpg" "C:\" /PIECHART "C:\Reports\D_pie.jpg" "D:\"

/PRINT

Druckt einen Bericht für die untersuchte Verzeichnisstruktur auf dem Standard-Drucker aus und beendet die Anwendung anschließend. Beispiel:

Treesize /PRINT "\\SERVER\USERS"

/READONLYMODE <Wert>

Diese Option aktiviert einen Nur-Lesen-Modus, wenn der Wert True übergeben wird, in dem Dateioperationen wie Löschen oder Verschieben deaktiviert sind. TreeSize ist in diesem Modus also nur noch als reine Reporting-Anwendung nutzbar.

Der Nur-Lesen-Modus kann mit dem Wert False wieder deaktiviert werden.

/RECYCLE

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Mit diesem Parameter werden Dateien, die als Ergebnisse der Dateisuche gefunden werden, in den Papierkorb verschoben. Beispiel:

Treesize /SEARCH:Start /FILTER "*.tmp" /RECYCLE "C:\temp"

Siehe auch: Dateioperationen

/RESTRICTEDMODE <Wert>

Diese Option aktiviert einen eingeschränkten Modus, wenn der Wert True übergeben wird, in dem viele Funktionen deaktiviert sind, die für "normale" Benutzer (nicht-Administratoren) nur von geringem Interesse sind. Dazu gehören: Auf Update überprüfen, Programme via Systemsteuerung deinstallieren, Geplante TreeSize Tasks erstellen und verwalten, Netzwerklaufwerk verbinden, Windows Systemwiederherstellung konfigurieren, Starten als Administrator, Exporte und das Anwenden der NTFS-Kompression. Sie können einen zu untersuchenden Pfad, beispielsweise das Home-Verzeichnis des Benutzers, an die Kommandozeile übergeben, oder die Option "Start" einer gespeicherten Konfigurationsdatei verwenden.

Der eingeschränkte Modus kann mit dem Wert False wieder deaktiviert werden.

Wenn Sie zusätzlich noch die Option /READONLYMODE aktivieren, kann der Benutzer in TreeSize keine Dateien löschen oder verschieben, es ist also nur noch als reine Reporting-Anwendung nutzbar.

/SCAN <Dateiname>

Untersucht alle Pfade, die sich in der nachfolgend spezifizierten Textdatei befinden. Die Textdatei muss einen Pfad pro Zeile enthalten. Das folgende Beispiel untersucht alle Pfade, die in der Datei "D:\PathsToScan.txt" aufgeführt sind, und schreibt jeden Scan in ein separates Arbeitsblatt einer Excel-Datei mit dem heutigen Datum:

Treesize /EXCEL "D:\Results\%DATE%.xlsx" /SCAN "D:\PathsToScan.txt"

Mit Hilfe einer "for" Schleife können Sie TreeSize auch mit jeweils nur einem Pfad aufrufen, ein Beispiel hierzu findet sich weiter unten auf dieser Seite.

/SEARCH

Öffnet das Fenster der Dateisuche von TreeSize. Wenn Sie zusätzlich ":Start" zu dieser Kommandozeilen-Option hinzufügen, wird die Suche unmittelbar gestartet. Es werden dieselben Einstellungen verwendet wie bei der letzten Benutzung der Dateisuche. Eine zuvor gespeicherte XML-Datei mit Sucheinstellungen kann übergeben werden, diese werden dann für die Suche verwendet. Alle gefundenen Dateien werden automatisch markiert. Das folgende Beispiel führt eine Suche durch mit den Suchoptionen, die zuvor in die Datei "SearchSettings.xml" gespeichert wurden, und exportiert die Ergebnisse in eine Textdatei:

Treesize /SEARCH:Start /TEXT "T:\SearchResult.txt" "SearchSettings.xml"

Tipp: Generell gilt, dass TreeSize immer die zuletzt benutzten Sucheinstellungen oder die mittels XML-Datei übergebenen Einstellungen für die Dateisuche benutzt. Sie können jedoch die Suchmuster der erweiterten Dateisuche auch mit Hilfe der Kommandozeilen-Option /FILTER explizit angeben.

/SHEETNAME <Titel>

Erlaubt es, den Namen des Arbeitsblattes festzulegen, das der Excel-Datei hinzugefügt wird, wenn die Kommandozeilen-Option /EXCEL verwendet wird. Bitte beachten Sie, dass der Name eine Tabellenblattes innerhalb einer Excel-Datei eindeutig sein muss, und dass bestimmte Sonderzeichen wie Schrägstrich, Backslash und Doppelpunkt in Namen eines Excel-Arbeitsblatt nicht erlaubt sind. TreeSize wird immer einen eindeutigen und gültigen Namen erzeugen, in dem es ungültige Zeichen durch einen Unterstrich ersetzt und bei Bedarf Datum und Uhrzeit hinzufügt. Existiert in der Zieldatei bereits ein Sheet mit dem angegebenen Namen, wird ein neues Sheet mit eindeutigem Namen erzeugt. Verwenden Sie die Kommandozeilen-Option /APPENDTOFILES, um die Daten auf dem bestehenden Sheet anzuhängen.

/SHORTDATEFORMAT <Format>

Erlaubt es, das kurze Datumsformat für diesen Prozess zu beeinflussen, welches normalerweise in den Optionen "Region und Sprache" der Windows Systemsteuerung einstellbar ist. Diese Format wir dann für Datumswerte in Exporten benutzt. Beispiel:

Treesize /SHORTDATEFORMAT YYYY-MM-DD /TEXT "D:\export.txt" "E:\"

/SIZEUNIT <N>

Mit dieser Option kann die Größeneinheit festgelegt werden, in der Größenangaben dargestellt werden sollen. N kann die Werte 0 bis 5 annehmen, wobei gilt: 0 = Bytes, 1 = KB, 2 = MB, 3 = GB, 4 = TB, 5 = automatische Einheit. Wird diese Option nicht verwendet, so wird der bei der letzten Benutzung von TreeSize verwendete Wert benutzt.

/SORTBY <Spaltename>

Erlaubt es festzulegen, nach welchen Werten (z.B. Größe oder Name) sortiert werden soll. Standardmäßig wird die zuletzt in TreeSize gewählte Einstellung verwendet. Als Spaltenname können die deutschen oder englischen Spaltennamen verwendet werden. Beispiel:

Treesize /SORTBY Größe /TEXT "D:\export.txt" "E:\"

Treesize /SORTBY Name /TEXT "D:\export.txt" "E:\"

/SUBJECT <Betreff>

Mit dieser Option kann festgelegt werden, welcher Betreff beim Senden einer E-Mail verwendet werden soll. Beispiel:

Treesize /EMAIL treesize@example.com /SUBJECT "TreeSize Professional Scan Report" "\\Server\Share"

/TEXT <Dateiname>

Speichert die Ergebnisse einer Untersuchung oder Dateisuche in einer Text- oder CSV-Datei, nachdem diese abgeschlossen ist, und beendet anschließen das Programm. Das folgende Beispiel speichert das Ergebnis einer Untersuchung Ihres lokalen Laufwerks C: in einer Textdatei:

Treesize /TEXT "C:\Results\C_scan.txt" "C:\"

Dieses Beispiel führt eine Dateisuche mit den letzten Einstellungen auf Ihrem lokalen Laufwerk C: aus und speichert das Ergebnis in einer CSV-Datei:

Treesize /SEARCH:Start /TEXT "C:\Results\C_search.csv" "C:\"

/TITLE <Titel>

Kann genutzt werden, um den Pfad eines Scans durch einen eigenen Text zu ersetzen. Dies ermöglicht zum Beispiel sprechendere Namen für unleserliche UNC-Pfade zu vergeben um damit die Übersichtlichkeit von Reports zu erhöhen. Ein Titel wird auf den jeweils folgenden Scan angewendet. Beispiel:

Treesize /TITLE "Laufwerk C: auf Datenserver 3" /PRINT "\\Server3\C$"

Treesize /TITLE "Laufwerk C: auf Datenserver 3" "\\Server3\C$" /TITLE "Laufwerk D: auf Datenserver 5" "\\Server5\D$"

Im Kontext der  TreeSize-Dateisuche kann mit diesem Parameter der Namen einer benutzerdefinierten Dateisuche geändert werden. Beispiel:

Treesize /SEARCH:Start /TITLE "Bilddateien" /FILTER "*.jpg;*.png;*.bmp" /PDF "C:\Results\C_search.pdf" "C:\"

/TOPFILESLIST <Dateiname>

Dieser Parameter erlaubt das Speichern der Top 100 Liste in einer Excel-, HTML-, Text- oder CSV-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /TOPFILESLIST "C:\temp\C_top_files.txt" "C:\"

/TREEMAP <Dateiname>

Speichert das Kacheldiagramm (Treemap chart) des untersuchten Verzeichnisbaums als Bitmap-, GIF-, PNG- oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /TREEMAP "C:\Dokumente\treemap.jpg" "C:\"

/USERSLIST <Dateiname>

Diese Option schreibt die Statistik über die Verteilung der Dateigrößen auf die verschiedenen Benutzer des untersuchten Dateisystemzweiges in eine Excel-, HTML-, Text- oder CSV-Datei. Die exportierten Spalten sind diejenigen, die zuvor in der Benutzeroberfläche auf dem Reiter "Benutzer" aktiviert waren, bzw. beim Export der via /OPTIONS übergebenen Konfigurationsdatei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine Excel-Datei in "C:\Temp" mit der Statistik der Benutzer auf diesem Laufwerk:

Treesize /USERSLIST "C:\Temp\C-Users.xls" "C:\"

/USERNAME <username>

Gibt den Benutzernamen an, der zu Authentifizierung verwendet werden soll. Verwenden Sie /PASSWORD um auch ein zum Benutzernamen passendes Passwort anzugeben. Wir empfehlen die Nutzung des Microsoft Tools RUNAS falls möglich.

/USERFILTER <Benutzername>

Mit dieser Option können Sie die beim Scan berücksichtigten Dateien auf einen bestimmten Benutzer einschränken. Geben Sie den Namen des Benutzers hinter diesem Parameter an. Sie können hier nur genau einen Benutzer angeben, aber es dürfen die Platzhalter "*" oder "?" benutzt werden. Beispiel:

Treesize /USERFILTER meier "\\Server\GroupDrive"

/USERSCHART <Dateiname>

Speichert das kleine Diagramm im unteren Bereich der Ansicht "Benutzer" in eine Grafikdatei (Bitmap, GIF, PNG oder JPEG).

/USERSPIECHART <Dateiname>

Speichert ein Kreisdiagramm, welches die Anteile der verschiedenen "Benutzer" am Platzverbrauch des aktuellen Scans zeigt, in eine Grafikdatei (Bitmap, GIF, PNG oder JPEG).

/VIEWTYPE n

Legt fest, auf welcher Basis die Werte der Spalte "Prozent", der "Zuwachs" Spalten und des  "Dateialter" Diagramms berechnet werden. Mögliche Werte sind:

2: Größe
3: Belegter Platz (Größe auf Datenträger)
7: Anzahl Dateien

/XML <Dateiname>

Speichert die Scanergebnisse in einer XML-Datei, die später wieder geladen oder für Vergleichszwecke genutzt werden kann. Beispiel:

Treesize /XML "C:\Results\Allusers.xml.zip" "H:\Users\"

Diese Option kann mit /EXPAND kombiniert werden, um die exportierten Verzeichnisse zu limitieren.
Hinweis: Wenn ein limitierter XML Export in TreeSize geladen wird kann man nicht die gesamte Verzeichnisstruktur betrachten, sondern nur die exportierten Verzeichnisse.

/ZIP <Dateiname>

Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden.
Mit diesem Parameter werden Dateien, die als Ergebnisse der Dateisuche gefunden werden, zu einer Zip-Datei zusammengefasst. Beispiel:

Treesize /SEARCH:Start /ZIP "C:\Scripts\Archive.zip" "C:\"

Siehe auch: Dateioperationen

<SCAN-PFAD>

Am Ende der Kommandozeile können ein oder mehrere Pfade angegeben werden, die TreeSize durchsuchen soll.
Mehrere Pfade müssen mit einem Leerzeichen getrennt angegeben werden. Pfade die Leerzeichen beinhalten müssen mit doppelten Hochkomma (") angegeben werden. Beispiel:

Treesize "C:\Program Files\" "C:\Windows"

Die Platzhalter "*" und "?" sind erlaubt. Beispiel:

Treesize "H:\Users\A*"

Um für jeden Unterordner einen eigene Instanz von TreeSize zu starten, können sie das Windows Kommando "for" wie folgt benutzen:

for /D %i in (H:\Users\A*) do @start /w Treesize.exe %i

Im Falle eines Fehlers wird der Windows Fehler-Code als Exit Code des Prozesses zurückgegeben. In Dateinamen für den Export und den zu untersuchenden Pfaden können Umgebungsvariablen von Windows (z.B.: %APPDATA%) verwendet werden.

Das Scannen mehrerer Verzeichnisse

Wenn Sie mehrere Verzeichnisse untersuchen wollen, kann es sinnvoll sein, mehrere Aufrufe der "TreeSize.exe" in einer Batch-Datei zusammenzufassen, zum Beispiel:

START /WAIT "TreeSize" "C:\Program Files\JAM Software\TreeSize\Treesize.exe" /EXCEL "D:\Share1.xls" "\\Server\Share1"

START /WAIT "TreeSize" "C:\Program Files\JAM Software\TreeSize\Treesize.exe" /EXCEL "D:\Share2.xls" "\\Server\Share2"

START /WAIT "TreeSIze" "C:\Program Files\JAM Software\TreeSize\Treesize.exe" /EXCEL "D:\Share3.xls" "\\Server\Share3"

Dass Kommando "START /WAIT" sorgt dafür, dass die Jobs nacheinander abgearbeitet werden. Die nicht-parallele Abarbeitung ist in der Regel zu empfehlen, da hier die Caches und Systemressourcen besser genutzt werden können. Es ist auch möglich, die Namen der Shares in eine Textdatei zu schreiben und das Windows Kommando "for" zu verwenden:

FOR /F %%p IN (Paths.txt) DO START /WAIT Treesize.exe /EXCEL "C:\Temp\TreeSize-Reports-%DATE%.xls" "%%p"

FOR /F "tokens=1" %%i IN (Shares.txt) DO START /WAIT Treesize.exe /EXCEL "C:\Temp\%%i.xls" "\\Server\%%i"

Hinweis: Die doppelten Prozentzeichen werden in Batch-Dateien benötigt, an der Kommandozeile ist ein einzelnes Prozentzeichen ausreichend.

Zeitgesteuerte Scans

Sie können die Windows-Aufgabenplanung verwenden, um zeitgesteuerte Untersuchungen täglich, wöchentlich oder monatlich durchzuführen. Die Funktion "TreeSize Scans planen" von TreeSize hilft Ihnen dabei.

Sie können auch das Windows Kommando "SCHTASKS" verwenden, um zeitgesteuerte Untersuchungen durchzuführen. Um beispielsweise eine Untersuchung der Laufwerke C: und E: um 3:00 Uhr nachts durchzuführen, können Sie folgendes Kommando an der Kommandozeile eingeben:

SCHTASKS /Create /SC TÄGLICH /ST 03:00 /TN TreeSizeScan /TR "'C:\Program Files\JAM Software\TreeSize\Treesize.exe' /EXCEL C:\Temp\tsp.xls /EXPAND 2 C:\ E:\"

Weitere Informationen zum Windows Kommando "SCHTASKS" erhalten Sie im hier oder mit dem Aufruf:

SCHTASKS /Create /?

Hinweis: Fehler bei der Ausführung werden im Ereignisprotokoll von Windows festgehalten.

PowerShell

Die Windows PowerShell kann sehr nützlich in Kombination mit TreeSize sein. Dieses Beispiel zeigt, wie eine Menge von Remote Computern auf Basis einer LDAP-Abfrage im Active Directory (AD) durchsucht werden können:

$computer = Get-ADComputer -SearchBase "ou=client computers,ou=intranet,dc=intranet,dc=jam-software,dc=com" -Filter *
foreach ($comp in $computer.name)
{
   $path = "\\$comp\C$\Windows"
   Add-Content Scan.txt "$path"
}
#debug
Get-Content -Path Scan.txt
# start TreeSize with the collected paths
&"C:\Program Files\JAM Software\TreeSize Professional\Treesize.exe" /SEARCH:Start /SCAN Scan.txt /FILTER *.exe /Export FoundFiles.txt

Ausgaben der Kommandozeile in eine Datei umleiten

Wenn kein anderes Ziel angegeben ist, schreibt TreeSize eine kurze Zusammenfassung der Scan-Ergebnisse und Fehler, die während dem Scan aufgetreten sind, auf die Kommandozeile.

Sie können diese Ausgaben in Dateien umleiten, indem Sie auf der Kommandozeile (cmd.exe) das Pipe-Symbol verwenden, z.B.:

"C:\Program Files\JAM Software\TreeSize\Treesize.exe" /NOGUI C:\ 1>StdOut.txt 2>StdError.txt

 

Um die Ausgaben auf der PowerShell umzuleiten, verwenden Sie bitte stattdessen Start-Process, z.B.:

Start-Process -FilePath "C:\Program Files\JAM Software\TreeSize\Treesize.exe" -ArgumentList "/NOGUI C:\" -RedirectStandardOutput ".\StdOut.txt" -RedirectStandardError ".\StdError.txt"

Windows Scripting Host

Wenn Sie den Windows Scripting Host (WSH) verwenden möchten, sieht das Kommando zum Starten wie folgt aus:

Set Shell = CreateObject("WScript.Shell")
Shell.Run """C:\Program Files\TreeSize\Treesize.exe"" /XML ""C:\Reports\Laufwerk-C.xml.zip"" ""C:\"""

Exit Codes

Wurde der Vorgang erfolgreich abgeschlossen, ist der Exit Code 0. Trat ein Fehler auf so liefert TreeSize als Exit Code falls vorhanden einen Windows Error Code zurück, oder 1 um einen allgemeinen Fehler anzuzeigen. In jedem Fall enthält die Windows Ereignisanzeige weiterere Informationen zu den aufgetretenen Fehlern im Protokoll "Anwendung", Quelle "TreeSize".